An error has occurred with the data fetch (in Google Chrome)

Jul 16, 2012 at 2:36 AM

Hi,

Great solution btw!!  I'm really keen to implement this solution and thus far have come across only 1 issue using Google Chrome.  When first loading the SharePoint site the My Links menu works fine, but when I visit another page in the site (doesn't matter where) and try the menu I receive the follow error from Chrome:

An error has occurred with the data fetch.  Please refresh the page and retry. 

Strangely enough, if I do refresh the page a couple of times the menu work ok.  Just wondering if you or anyone else has come across this before?

Thanks again for all your hard work!

deano.

Coordinator
Jul 16, 2012 at 7:17 PM

Hi Deano,

I actually use Chrome as my primary browser and have never seen this error. Is the message displayed in place of the My Links menu or is it a JavaScript/browser error?

Thanks,
Randy 

Jul 17, 2012 at 11:26 PM

Hi Randy,

It does seem to be a JavaScript / Browser error as it pops up in an alert box giving the option to "Prevent this page from creating additional dialogues".  I'm wondering if it's due to the fact I've repositioned the DelegateControl in our custom Master page ... it now sits in a banner at the top of our masterpage, with the Welcome menu as per below:

   <SharePoint:DelegateControl runat="server" ID="GlobalDelegate0" ControlId="GlobalSiteLink0" />
   <div class="s4-trc-container-menu">
    <div class="Custom-Welcome">
     <wssuc:Welcome id="IdWelcome" runat="server" EnableViewState="false" />     
     <wssuc:MUISelector ID="IdMuiSelector" runat="server"/>
    </div>
   </div>

Either way, at least I now it must be something on our end if yourself and others are using chrome with no issue ...

thanks again,

deano.

Jul 17, 2012 at 11:56 PM

Just to update Randy, you've pointed me in the right direction in that it was JavaScript related ... we do some custom branding with our Web Parts Chrome and a particular jquery function was causing the issue ... all sorted!

Thank you again for a top solution !

deano.

 

Coordinator
Jul 18, 2012 at 1:16 PM

Thanks for the update, I'm glad to hear you got it working.

Randy